summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-08-28 10:27:53 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-28 10:29:22 +0200
commitd81b89bf0231c1a994d5f54bc60002f434a3f567 (patch)
treeece26cd02bd01a3672900c50e8fa676fa575a41b /gnu
parent36a09d185343375a5cba370431870f9c4435d623 (diff)
downloadguix-d81b89bf0231c1a994d5f54bc60002f434a3f567.tar.gz
gnu: rottlog: Do not refer to the canonical coreutils.
* gnu/packages/admin.scm (rottlog)[inputs]: Add "coreutils",
[arguments]: and use it in the 'tweak-rc-weekly phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5efe67b0cb..6610b8f5c1 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1365,10 +1365,11 @@ at once based on a Perl regular expression.")
                          "packdir=\"/var/log\""))
                       #t))
                   (add-before 'install 'tweak-rc-weekly
-                    (lambda _
+                    (lambda* (#:key inputs #:allow-other-keys)
                       (substitute* "rc/weekly"
                         (("/bin/kill")
-                         (which "kill"))
+                         (string-append (assoc-ref inputs "coreutils*")
+                                        "/bin/kill"))
                         (("syslogd\\.pid")
                          ;; The file is called 'syslog.pid' (no 'd').
                          "syslog.pid"))
@@ -1379,6 +1380,7 @@ at once based on a Perl regular expression.")
     (native-inputs `(("texinfo" ,texinfo)
                      ("automake" ,automake)
                      ("util-linux" ,util-linux))) ; for 'cal'
+    (inputs `(("coreutils*" ,coreutils)))
     (home-page "https://www.gnu.org/software/rottlog/")
     (synopsis "Log rotation and management")
     (description