summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-07-17 00:01:38 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-17 00:01:38 +0200
commite4d801623e7a64b3de8aadd00b5e4a1aa34728a7 (patch)
tree318b4c8c42ef3d061e11c921dd720b8903d87958 /gnu
parent81e558fdb16386c34db53c540e20b8d633ae3a64 (diff)
downloadguix-e4d801623e7a64b3de8aadd00b5e4a1aa34728a7.tar.gz
gnu: libpsl: Update to 0.7.1.
Removing the 'snippet' allows us to avoid 'patch-and-repack', which resets all
the mtimes, thereby breaking the expectation tested in
'test-is-public-builtin.c' that the mtime returned by 'psl_builtin_file_time'
is non-zero.

* gnu/packages/web.scm (libpsl): Update to 0.7.1.
  [source]: Remove 'modules' and 'snippet'.
  [native-inputs]: Add PKG-CONFIG.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 99a176f9d5..9a20b30e92 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -320,20 +320,15 @@ for efficient socket-like bidirectional reliable communication channels.")
 (define-public libpsl
   (package
     (name "libpsl")
-    (version "0.6.0")
+    (version "0.7.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/rockdaboot/libpsl/"
                                   "archive/" version ".tar.gz"))
               (sha256
                (base32
-                "10s7xxxx6pp4ydp3san69sa6q379ih3pv92fyi565ggmlw8igv7a"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (modules '((guix build utils)))
-              (snippet
-               ;; Believe it or not, the .pc is invalid.  Fix it.
-               '(substitute* "libpsl.pc.in"
-                  (("-llibpsl") "-lpsl")))))
+                "1k0klj668c9v0r4993vfs3kq773mzdz61vsigqw6v1mjcwnf1si3"))
+              (file-name (string-append name "-" version ".tar.gz"))))
     (build-system gnu-build-system)
     (inputs `(("icu4c" ,icu4c)))
     ;; The release tarball lacks the generated files.
@@ -341,7 +336,8 @@ for efficient socket-like bidirectional reliable communication channels.")
                      ("automake" ,automake)
                      ("gettext"  ,gnu-gettext)
                      ("which"    ,which)
-                     ("libtool"  ,libtool)))
+                     ("libtool"  ,libtool)
+                     ("pkg-config" ,pkg-config)))
     (arguments
      `(#:phases (alist-cons-after
                  'unpack 'bootstrap