summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-29 20:13:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-29 22:06:01 +0200
commit05e0ac46ef0118b92f6d9002a2c4333c22c89423 (patch)
tree291ce9905221472c7d92855b0fa1b88ccc7f7680 /gnu
parent3f1271474252db144c1f1e2ef4e7aead1349eb52 (diff)
downloadguix-05e0ac46ef0118b92f6d9002a2c4333c22c89423.tar.gz
gnu: retroarch: Don't use %OUTPUT.
* gnu/packages/games.scm (retroarch)[arguments]: Accept an OUTPUTS key
in the configure phase.  Add a comment about the script.  Use LET*.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0071056c45..b4498c6a38 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1096,17 +1096,21 @@ either by Infocom or created using the Inform compiler.")
         (base32 "1xar0wagcz50clwwkvjg4zq9m1sjqw47vw3xx44pisdj94g21m5y"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f ; no tests
+     '(#:tests? #f                      ; no tests
        #:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda _
-             (substitute* "qb/qb.libs.sh"
-               (("/bin/true") (which "true")))
-             (zero? (system*
-                     "./configure"
-                     (string-append "--prefix=" %output)
-                     (string-append "--global-config-dir=" %output "/etc"))))))))
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (etc (string-append out "/etc")))
+               (substitute* "qb/qb.libs.sh"
+                 (("/bin/true") (which "true")))
+               ;; The configure script does not yet accept the extra arguments
+               ;; (like ‘CONFIG_SHELL=’) passed by the default configure phase.
+               (zero? (system*
+                       "./configure"
+                       (string-append "--prefix=" out)
+                       (string-append "--global-config-dir=" etc)))))))))
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("ffmpeg" ,ffmpeg)