summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-04-29 17:53:50 -0500
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-05-16 14:48:57 -0500
commit11e4c1fd104884999a84633baea1d2e298d2e334 (patch)
tree5b9ee37b00ffa7c4d48970810533b8371f11e81a /gnu
parent9916ae15bb7622fb75f819d561cbc2c4257d0acd (diff)
downloadguix-11e4c1fd104884999a84633baea1d2e298d2e334.tar.gz
gnu: Add geiser-next.
Also, I previously committed to this repository in 2015; add self to copyright
headers for that year too.

* gnu/packages/emacs.scm (geiser-next): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 11010b2a47..f0c1555f7d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 Nils Gillmann <niasterisk@grrlz.net>
 ;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
+;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -260,6 +261,36 @@ implementation, Emacs and, ultimately, the schemer, giving them access to live
 metadata.")
     (license license:bsd-3)))
 
+(define-public geiser-next
+  ;; Geiser's upcoming version supports guile-next, and 0.8.1 does not.
+  ;; When the next Geiser release comes out, we can remove this.
+  (let ((commit "2e335695fc1a4a0b520b50deb761b958194cbec4"))
+    (package
+      (inherit geiser)
+      (name "geiser-next")
+      (version (string-append "0.8.1-1"
+                              (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "git://git.sv.gnu.org/geiser.git")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "00rmpn8zncq1fiah5m12l26z0s28bh7ql63kxdvksqdgfrisnmgf"))))
+      (native-inputs
+       `(("autoconf" ,autoconf)
+         ("automake" ,automake)
+         ("texinfo" ,texinfo)
+         ,@(package-native-inputs geiser)))
+      (arguments
+       (substitute-keyword-arguments (package-arguments geiser)
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (add-after 'unpack 'autogen
+               (lambda _
+                 (zero? (system* "sh" "autogen.sh")))))))))))
+
 (define-public paredit
   (package
     (name "paredit")