summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-09-19 12:15:07 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-09-19 15:44:20 +1000
commit4b1a15282677b15a5949ec144567529f70260203 (patch)
tree01c9c358432ca491ed0a2b25b7dde38804beaaf8 /gnu
parent8c8da1389e476356ce5086b5cff4874d41271b96 (diff)
downloadguix-4b1a15282677b15a5949ec144567529f70260203.tar.gz
gnu: Add python2-biopython-1.66.
* gnu/packages/bioinformatics.scm (python2-biopython-1.66): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a8d2cf3ea2..5effc80a4c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -630,6 +630,20 @@ into separate processes; and more.")
       (native-inputs `(("python2-setuptools" ,python2-setuptools)
                        ,@(package-native-inputs base))))))
 
+;; An outdated version of biopython is required for seqmagick, see
+;; https://github.com/fhcrc/seqmagick/issues/59
+;; When that issue has been resolved this package should be removed.
+(define python2-biopython-1.66
+  (package
+    (inherit python2-biopython)
+    (version "1.66")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "biopython" version))
+              (sha256
+               (base32
+                "1gdv92593klimg22icf5j9by7xiq86jnwzkpz4abaa05ylkdf6hp"))))))
+
 (define-public bpp-core
   ;; The last release was in 2014 and the recommended way to install from source
   ;; is to clone the git repository, so we do this.