summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-18 13:14:12 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-19 16:57:44 +0100
commit882d579d3fc3ffefe2e5f50b7d5dac22a24a4421 (patch)
tree79d30e1a4b491d4ba9fbd34c912e81188e256c23 /gnu
parentd2ad4f2e00da3bcf1a87be16c0b456255e7a5f79 (diff)
downloadguix-882d579d3fc3ffefe2e5f50b7d5dac22a24a4421.tar.gz
gnu: dcmtk: Update to 3.6.4.
* gnu/packages/image-processing.scm (dcmtk): Update to 3.6.4.
[inputs]: Add libjpeg.  Order alphabetically.  Move doxygen…
[native-inputs]: …here.  Remove perl.  Order alphabetically.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image-processing.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 54ff39fb81..a5e9969bfe 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2018 Lprndn <guix@lprndn.info>
 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -65,29 +65,27 @@
   #:use-module (gnu packages xorg)
   #:use-module (ice-9 match))
 
-;; We use the latest snapshot of this package because the latest release is
-;; from 2011 and has known vulnerabilities that cannot easily be fixed by
-;; applying patches.
 (define-public dcmtk
   (package
     (name "dcmtk")
-    (version "3.6.1_20170228")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "ftp://dicom.offis.de/pub/dicom/offis/"
-                                  "software/dcmtk/snapshot/dcmtk-"
-                                  version ".tar.gz"))
-              (sha256
-               (base32
-                "04cwfx8yrscqcd59mxk2fh6314ckayi9cp68iql5a57pf2pg5qld"))))
-    (build-system gnu-build-system)
+    (version "3.6.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "ftp://dicom.offis.de/pub/dicom/offis/software/dcmtk/"
+                       "dcmtk" (string-join (string-split version #\.) "")
+                       "/dcmtk-" version ".tar.gz"))
+       (sha256
+        (base32 "1h22z8g0kmvhg8lgkbikyzyphhvxvq6018a00yd6i4g0z9ag6gx9"))))
+    (build-system cmake-build-system)
     (inputs
-     `(("libtiff" ,libtiff)
+     `(("libjpeg" ,libjpeg)
        ("libpng" ,libpng)
-       ("doxygen" ,doxygen)
+       ("libtiff" ,libtiff)
        ("zlib" ,zlib)))
     (native-inputs
-     `(("perl" ,perl)))
+     `(("doxygen" ,doxygen)))           ; for HTML documentation
     (home-page "https://dcmtk.org")
     (synopsis "Libraries and programs implementing parts of the DICOM standard")
     (description "DCMTK is a collection of libraries and applications