summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 18:20:21 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:33:49 +0100
commite93281507d40c8b4f0c1e967c714c3c86a270b82 (patch)
tree158cbfb4e0f8b05dd5a617164cf77abfbf5dc503 /gnu
parenta58118ca6b1b4f971e997675ccdff5def0b0b3c3 (diff)
downloadguix-e93281507d40c8b4f0c1e967c714c3c86a270b82.tar.gz
gnu: Add ocaml-ppx-sexp-value.
* gnu/packages/ocaml.scm (ocaml-ppx-sexp-value): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 549bc15610..7e4ab5715f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5536,3 +5536,29 @@ many values).")
     (synopsis "Typerep is a library for runtime types")
     (description "Typerep is a library for runtime types.")
     (license license:asl2.0)))
+
+(define-public ocaml-ppx-sexp-value
+  (package
+    (name "ocaml-ppx-sexp-value")
+    (version "0.11.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+                                  (version-major+minor version)
+                                  "/files/ppx_sexp_value-v" version ".tar.gz"))
+              (sha256
+               (base32
+                "1xnalfrln6k5khsyxvxkg6v32q8fpr4cqamsjqfih29jdv486xrs"))))
+    (build-system dune-build-system)
+    (propagated-inputs
+      `(("ocaml-base" ,ocaml-base)
+        ("ocaml-ppx-here" ,ocaml-ppx-here)
+        ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+        ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+        ("ocaml-ppxlib" ,ocaml-ppxlib)))
+    (properties `((upstream-name . "ppx_sexp_value")))
+    (home-page "https://github.com/janestreet/ppx_sexp_value")
+    (synopsis "Simplify building s-expressions from ocaml values")
+    (description "A ppx rewriter that simplifies building s-expressions from
+ocaml values.")
+    (license license:asl2.0)))