summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-01-21 10:43:02 +0000
committerChristopher Baines <mail@cbaines.net>2018-01-30 07:41:29 +0000
commit60a8cbc4b7ed5772263c113aa07af594e854739a (patch)
tree5e13a95efaf28a55fa52b59b143c410c1b4f9560 /gnu
parentf8ce6eb6d22f87dccac4a98813ff5cd51598c468 (diff)
downloadguix-60a8cbc4b7ed5772263c113aa07af594e854739a.tar.gz
gnu: Add go-github.com-jessevdk-go-flags.
* gnu/packages/golang.scm (go-github.com-jessevdk-go-flags): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f21149a0ff..323786c6d4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -446,3 +446,28 @@ interfaces in Go.  The goal is to enable developers to write fast and
 distributable command line applications in an expressive way.")
       (home-page "https://github.com/davidjpeacock/cli")
       (license license:expat))))
+
+(define-public go-github.com-jessevdk-go-flags
+  (package
+    (name "go-github.com-jessevdk-go-flags")
+    (version "1.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jessevdk/go-flags")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1jk2k2l10lwrn1r3nxdvbs0yz656830j4khzirw8p4ahs7c5zz36"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/jessevdk/go-flags"))
+    (synopsis "Go library for parsing command line arguments")
+    (description
+     "The @code{flags} package provides a command line option parser.  The
+functionality is similar to the go builtin @code{flag} package, but
+@code{flags} provides more options and uses reflection to provide a succinct
+way of specifying command line options.")
+    (home-page "https://github.com/jessevdk/go-flags")
+    (license license:bsd-3)))