summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 16:57:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 17:13:52 +0100
commit728012dae8bbba2fd006300bfd046aa6b99846ae (patch)
tree383b5503328425188143ca7b60490c62df51b5b1 /gnu
parent7aeec0cf374b9d911410ab87fd2fe985edad2430 (diff)
downloadguix-728012dae8bbba2fd006300bfd046aa6b99846ae.tar.gz
gnu: Add r-etm.
* gnu/packages/cran.scm (r-etm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f073124151..481dcc1457 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10224,3 +10224,29 @@ of a competing risk, Ann. Stat. 16:1141-1154, and Fine JP and Gray RJ (1999),
 A proportional hazards model for the subdistribution of a competing risk,
 JASA, 94:496-509.")
     (license license:gpl2+)))
+
+(define-public r-etm
+  (package
+    (name "r-etm")
+    (version "1.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "etm" version))
+       (sha256
+        (base32
+         "0ws103b3pmli0z4xbyfxkly2wnnnxnnwc0r66qjjqjrlvm7pffl1"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-data-table" ,r-data-table)
+       ("r-lattice" ,r-lattice)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcpparmadillo" ,r-rcpparmadillo)
+       ("r-survival" ,r-survival)))
+    (home-page "https://cran.r-project.org/web/packages/etm")
+    (synopsis "Empirical transition matrix")
+    (description
+     "The @dfn{empirical transition matrix} (etm) package permits to estimate
+the matrix of transition probabilities for any time-inhomogeneous multistate
+model with finite state space using the Aalen-Johansen estimator.")
+    (license license:expat)))