summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 04:57:28 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 05:41:17 +0100
commit7d4cbd993d44d477d0fd6d7f308efe7f41fc0d97 (patch)
tree8417785322f05e17753ad2173ad2ac6460c86339 /gnu
parentf95114e5dd9ae56581c730b73149de28d2765ce7 (diff)
downloadguix-7d4cbd993d44d477d0fd6d7f308efe7f41fc0d97.tar.gz
gnu: ifdtool: Update to 4.9.
* gnu/packages/flashing-tools.scm (ifdtool): Update to 4.9.
[source]: Update source URI.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/flashing-tools.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index bc4bbd876a..aeef2f340c 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -341,16 +341,16 @@ referred to as the \"Odin 3 protocol\".")
 (define-public ifdtool
   (package
     (name "ifdtool")
-    (version "4.7")
+    (version "4.9")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://review.coreboot.org/p/coreboot")
+                    (url "https://github.com/coreboot/coreboot.git")
                     (commit version)))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0nw555i0fm5kljha9h47bk70ykbwv8ddfk6qhz6kfqb79vzhy4h2"))))
+                "0jidj29jh6p65d17k304wlzhxvp4p3c2namgcdwg2sxq8jfr0zlm"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
@@ -359,12 +359,12 @@ referred to as the \"Odin 3 protocol\".")
              (string-append "PREFIX=" (assoc-ref %outputs "out")))
        #:phases
        (modify-phases %standard-phases
-        (add-after 'unpack 'chdir
-          (lambda _
-            (chdir "util/ifdtool")
-            #t))
-        (delete 'configure)
-        (delete 'check))))
+         (add-after 'unpack 'chdir
+           (lambda _
+             (chdir "util/ifdtool")
+             #t))
+         (delete 'configure))           ; no configure script
+       #:tests? #f))                    ; no test suite
     (home-page "https://github.com/corna/me_cleaner/")
     (synopsis "Intel Firmware Descriptor dumper")
     (description "This package provides @command{ifdtool}, a program to