summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-03-10 18:32:25 +1100
committerLeo Famulari <leo@famulari.name>2021-04-09 16:09:25 -0400
commitdde1c7655d697a12ef18792ae732f51cdd9de32a (patch)
treef20c03f8268f482cb257365ea394e7295ebaa451 /gnu
parent852f9324857c616da7d74a9aede83016e9082fc0 (diff)
downloadguix-dde1c7655d697a12ef18792ae732f51cdd9de32a.tar.gz
gnu: Add python-pyzstd
* gnu/packages/python-compression.scm (python-pyzstd): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-compression.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index f87eacc853..ab2eca2743 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -363,3 +363,21 @@ wrapper.  It provides a backport of the @code{Path} object.")
 the Zstandard compression library.  A C extension and CFFI interface are
 provided.")
     (license license:bsd-3)))
+
+(define-public python-pyzstd
+  (package
+    (name "python-pyzstd")
+    (version "0.14.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyzstd" version))
+       (sha256
+        (base32
+         "1d3mngs45w2p490vrq5ymd2wz4lp15phmks1ilcx4k7amgibml3d"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/animalize/pyzstd")
+    (synopsis "Zstandard bindings for Python")
+    (description "This package provides Python bindings to the Zstandard (zstd)
+compression library.  The API is similar to Python's bz2/lzma/zlib module.")
+    (license license:bsd-3)))