summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 16:54:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 17:13:52 +0100
commite3c0e3e36033f9f46e7c8460c86b16cf9e8298ec (patch)
tree9fb04f3d4a72ca617142c4da5ce8217a943dcbd6 /gnu
parentfe4e9f03492521f641e326cb21108367a44b1a63 (diff)
downloadguix-e3c0e3e36033f9f46e7c8460c86b16cf9e8298ec.tar.gz
gnu: Add r-protviz.
* gnu/packages/cran.scm (r-protviz): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e10465bb46..5204677380 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10170,3 +10170,30 @@ putative directions).")
      "This package provides an R interface to functions of the SAMtools
 library.")
     (license license:artistic2.0)))
+
+(define-public r-protviz
+  (package
+    (name "r-protviz")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "protViz" version))
+       (sha256
+        (base32
+         "1im3ajimycsc1zpzbihxlsibjk0462q0vldy7v5ypsqnjbi1ndxm"))))
+    (properties `((upstream-name . "protViz")))
+    (build-system r-build-system)
+    (inputs
+     `(("perl" ,perl)
+       ("python-2" ,python-2)))
+    (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/protViz/protViz/")
+    (synopsis "Visualizing and analyzing mass spectrometry data in proteomics")
+    (description
+     "This package helps with quality checks, visualizations and analysis of
+mass spectrometry data, coming from proteomics experiments.  The package is
+developed, tested and used at the Functional Genomics Center Zurich, where it
+is used mainly for prototyping, teaching, and having fun with proteomics data.
+But it can also be used to do data analysis for small scale data sets.")
+    (license license:gpl3)))