summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-10-20 12:37:54 +0200
committerLeo Famulari <leo@famulari.name>2020-12-15 01:55:37 -0500
commit0386f3a69e6c7c2e0e31cf7a61bcecd6c9dcab50 (patch)
tree63973006405dc6729ef58fd2e32d410526d05816 /gnu
parent56cfef47664879f2e976c6097f16dfb135733d84 (diff)
downloadguix-0386f3a69e6c7c2e0e31cf7a61bcecd6c9dcab50.tar.gz
gnu: Add python-hstspreload.
* gnu/packages/python-web.scm (python-hstspreload): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9195b8328c..b409edc551 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5653,3 +5653,24 @@ over IMAP:
 @item Work with mailbox folders (list, set, get, create, exists, rename, delete, status)
 @end itemize")
     (license license:asl2.0)))
+
+(define-public python-hstspreload
+  (package
+    (name "python-hstspreload")
+    (version "2020.10.20")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hstspreload" version))
+       (sha256
+        (base32
+         "1qah80p2xlib1rhivvdj9v5y3girxrj7dwp1mnh8mwaj5wy32y8a"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/sethmlarson/hstspreload")
+    (synopsis
+     "Chromium HSTS Preload list as a Python package")
+    (description
+     "@code{python-hstspreload} contains Chromium HSTS Preload list
+as a Python package.")
+    (license license:bsd-3)))