summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-18 15:30:20 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-18 15:30:20 +0000
commit0525a3de76206a1df57f448dde5f4f8addbdbcdf (patch)
tree81af6bec49ca56d1e08d2086fb3a4d0e916282f9 /gnu
parent4b8bc321e1ba48a7e270758cf36b9196097d31c4 (diff)
downloadguix-0525a3de76206a1df57f448dde5f4f8addbdbcdf.tar.gz
gnu: python-pymediainfo: Simplify check phase.
* gnu/packages/python-xyz.scm (python-pymediainfo)[arguments]: Use
ADD-INSTALLED-PYTHONPATH instead of manipulating PYTHONPATH directly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5f99073d93..240955c413 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -940,13 +940,11 @@ to CommonMark.")
                 (search-input-file %build-inputs
                                    "/lib/libmediainfo.so.0")))))
          (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
              (when tests?
-               ;; Extend PYTHONPATH so the built package will be found.
-               (setenv "PYTHONPATH"
-                       (string-append (getcwd) "/build/lib:"
-                                      (getenv "PYTHONPATH")))
-               ;; Skip the only failing test "test_parse_url"
+               (add-installed-pythonpath inputs outputs)
+               ;; Skip the only failing test "test_parse_url" because it tries
+               ;; to access the internet.
                (invoke "pytest" "-vv" "-k" "not test_parse_url")))))))
     (home-page
      "https://github.com/sbraz/pymediainfo")