summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-23 23:01:50 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:51 -0500
commit0c9844e1d64d480a8785a245e6d67a9ada86751d (patch)
treea94ef4bce4aef2fa0e6761370ec9d2dccc49b632 /gnu
parent10bee15c8209b762c336d8632df3f890f048e5c3 (diff)
downloadguix-0c9844e1d64d480a8785a245e6d67a9ada86751d.tar.gz
gnu: python-fenics-fiat: Do not alter PYTHONPATH.
* gnu/packages/simulation.scm (python-fenics-fiat)
[phases]{check}: Do not alter PYTHONPATH.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/simulation.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index f78237a3c8..de15ade5b6 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -344,8 +344,6 @@ UFL is part of the FEniCS Project.")
        (modify-phases %standard-phases
          (replace 'check
            (lambda _
-             (setenv "PYTHONPATH"
-                     (string-append (getcwd) ":" (getenv "PYTHONPATH")))
              (with-directory-excursion "test"
                ;; FIXME: three FIAT test modules are known to fail
                ;; with recent versions of pytest (>= 4).  These are
@@ -355,8 +353,7 @@ UFL is part of the FEniCS Project.")
                (invoke "py.test" "unit/"
                        "--ignore=unit/test_fiat.py"
                        "--ignore=unit/test_quadrature.py"
-                       "--ignore=unit/test_reference_element.py"))
-             #t)))))
+                       "--ignore=unit/test_reference_element.py")))))))
     (home-page "https://bitbucket.org/fenics-project/fiat/")
     (synopsis "Tabulation of finite element function spaces")
     (description