summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-26 17:38:24 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:15 +0100
commit1ed89fc485fb6f04c882ab445ddc70106c5478f0 (patch)
treefe685a8cd202ea67348f4836259fbba1c59e5d82 /gnu
parent94c6b9068b8e07250528148294e10f9c212aa6f4 (diff)
downloadguix-1ed89fc485fb6f04c882ab445ddc70106c5478f0.tar.gz
gnu: Add plasma-welcome.
* gnu/packages/kde-plasma.scm (plasma-welcome): New package.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-plasma.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 9bebd4cafd..1fa41e5004 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -2139,6 +2139,45 @@ sensors, process information and other system resources.")
     (home-page "https://invent.kde.org/plasma/plasma-systemmonitor")
     (license (list license:gpl2 license:gpl3))))
 
+(define-public plasma-welcome
+(let ((commit "dac7569078782a96f122782c15d34e51737d2b89") ; no tags
+      (revision "1"))
+  (package
+    (name "plasma-welcome")
+    (version (git-version "0.1-pre" revision commit))
+    (home-page "https://invent.kde.org/plasma/plasma-welcome")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference (url home-page) (commit commit)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1x7ra699r5a9kpa3isdnx6af4j6778kw2pmprnx4s8f1rwk2idhh"))))
+    (build-system qt-build-system)
+    (native-inputs
+     (list extra-cmake-modules pkg-config))
+    (inputs
+     (list kcoreaddons
+           kdbusaddons
+           kdeclarative
+           ki18n
+           kio
+           kirigami
+           knotifications
+           kservice
+           kwindowsystem
+           networkmanager-qt
+           plasma-framework
+           qtdeclarative-5
+           qtgraphicaleffects
+           qtsvg-5
+           qtquickcontrols2-5
+           system-settings))
+    (synopsis "Plasma welcome screen")
+    (description
+     "This package provides a wizard for Plasma to configure settings.")
+    (license (list license:gpl2 license:gpl3)))))
+
 (define-public plasma-workspace
   (package
     (name "plasma-workspace")