summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-09 02:06:58 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-10 00:32:34 +0100
commit294476022f19139e290acb448d4575de0f851673 (patch)
tree6a4b3201bd4666ca8f2fe0b9dbe14f242d6352b7 /gnu
parente2d8125a5c6d4338749e6bf8882f220395b25275 (diff)
downloadguix-294476022f19139e290acb448d4575de0f851673.tar.gz
gnu: libportal: Update to 0.5.
* gnu/packages/freedesktop.scm (libportal): Update to 0.5.
[arguments]: Add #:configure-flags to limit dependency creep.
Remove 'move-doc phase.
[native-inputs]: Remove gtk-doc.  Add gobject-introspection and vala.
[inputs]: Add gtk, gtk+, qtbase-5, and qtx11extras.
[outputs]: Remove :out.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm30
1 files changed, 14 insertions, 16 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index dcd1870e41..c927d8e4dc 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -103,6 +103,7 @@
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages rdesktop)
   #:use-module (gnu packages rsync)
   #:use-module (gnu packages samba)
@@ -2219,7 +2220,7 @@ fallback to generic Systray support if none of those are available.")
 (define-public libportal
   (package
     (name "libportal")
-    (version "0.4")
+    (version "0.5")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2228,30 +2229,27 @@ fallback to generic Systray support if none of those are available.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1jh6wd96y4i218zbmmqw12zir8p88nm8dlsa3yx3lsqxd5c1krky"))))
+                "0i4v0wjyiryg7jq9hp9iaplqyhwj1cqy5891s4jfldcdzvcwxwx0"))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'move-doc
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out"))
-                   (doc (assoc-ref outputs "doc"))
-                   (html "/share/gtk-doc"))
-               (copy-recursively (string-append out html)
-                                 (string-append doc html))
-               (delete-file-recursively (string-append out html))
-               #t))))))
+     `(#:configure-flags
+       (list "-Dbackends=gtk4,qt5"
+             "-Ddocs=false")))          ; requires unpackaged gi-docgen
     (native-inputs
      `(("pkg-config" ,pkg-config)
-       ("gtk-doc" ,gtk-doc/stable)
        ("docbook-xsl" ,docbook-xsl)
        ("docbook-xml" ,docbook-xml)
+       ("glib:bin" ,glib "bin")
+       ("gobject-introspection" ,gobject-introspection)
        ("libxml2" ,libxml2)
-       ("glib:bin" ,glib "bin")))
+       ("vala" ,vala)))
+    (inputs
+     (list gtk
+           gtk+
+           qtbase-5
+           qtx11extras))
     (propagated-inputs
      (list glib))
-    (outputs '("out" "doc"))
     (home-page "https://github.com/flatpak/libportal")
     (synopsis "Flatpak portal library")
     (description