summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJ. Sims <jtsims@protonmail.com>2022-10-05 19:37:11 -0500
committerLudovic Courtès <ludo@gnu.org>2022-10-09 22:32:14 +0200
commit31f0e46bea4028d2830f384afeaa7999004716c5 (patch)
tree2e7a9ace38cd4a8b2ecf5cf46ed42821ac452495 /gnu
parentb5e83548fb83f8f64743fd258944f172c96a0a50 (diff)
downloadguix-31f0e46bea4028d2830f384afeaa7999004716c5.tar.gz
gnu: Add genie.
* gnu/packages/build-tools.scm (genie): Add genie.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/build-tools.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 84a62d0fd6..376c4d3486 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -14,6 +14,7 @@
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Juliana Sims <jtsims@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -763,3 +764,35 @@ Build has features such as:
 @item Extensible language/compiler framework.
 @end itemize")
     (license license:gpl2+)))
+
+(define-public genie
+  (let ((commit "b139103697bbb62db895e4cc7bfe202bcff4ff25")
+        (revision "0"))
+    (package
+      (name "genie")
+      (version (git-version "1167" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/bkaradzic/genie")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "16plshzkyjjzpfcxnwjskrs7i4gg0qn92h2k0rbfl4a79fgmwvwv"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list #:phases #~(modify-phases %standard-phases
+                          (delete 'configure)
+                          (replace 'install
+                            (lambda _
+                              (install-file "bin/linux/genie"
+                                            (string-append #$output "/bin")))))
+             #:tests? #f)) ;no tests
+      (home-page "https://github.com/bkaradzic/genie")
+      (synopsis "Project generator")
+      (description
+       "GENie generates projects from Lua scripts, making it easy to apply the
+same settings to multiple projects.  It supports generating projects using GNU
+Makefiles, JSON Compilation Database, and experimentally Ninja.")
+      (license license:bsd-3))))