summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 11:45:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:45:24 +0200
commit3d111f14302e99dd4bcd1d8d60fdde312cd027c0 (patch)
tree9e45112b0ffac3096b33e1c806bb950b10084856 /gnu
parent5e3199e37b6fc9494d91d68de4eb90e6d48916de (diff)
downloadguix-3d111f14302e99dd4bcd1d8d60fdde312cd027c0.tar.gz
gnu: Add r-zonebuilder.
* gnu/packages/cran.scm (r-zonebuilder): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7fc9f180d8..98ed932014 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31115,3 +31115,31 @@ package provides analytical tools to make inferences on zooarchaeological
 data.  Functions in this package allow users to read, manipulate, visualize,
 and analyze zooarchaeological data.")
     (license license:gpl2+)))
+
+(define-public r-zonebuilder
+  (package
+    (name "r-zonebuilder")
+    (version "0.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "zonebuilder" version))
+       (sha256
+        (base32
+         "0mxf3dz0d6bi5wwjilqivdxhy5ypnq5svky8zygha0clv45l4dmn"))))
+    (properties `((upstream-name . "zonebuilder")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-sf" ,r-sf)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/zonebuilders/zonebuilder")
+    (synopsis "Create and explore geographic zoning systems")
+    (description
+     "This package provides functions, documentation and example data to help
+divide geographic space into discrete polygons (zones).  The functions are
+motivated by research into the merits of different zoning systems.  A flexible
+@code{ClockBoard} zoning system is provided, which breaks-up space by
+concentric rings and radial lines emanating from a central point.")
+    (license license:gpl3)))