summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-30 15:50:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-30 15:50:20 +0200
commit3e63f078daf1fa78966cb9d050b870ca32cbb367 (patch)
tree1a89228fbd464f999106cd369c8b81749de71e44 /gnu
parent37120e7a2385cc6a4e5a3c955df810ed0e0b88aa (diff)
downloadguix-3e63f078daf1fa78966cb9d050b870ca32cbb367.tar.gz
gnu: Add r-pbmcapply.
* gnu/packages/cran.scm (r-pbmcapply): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9eec520b8f..ab5c94d766 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14314,6 +14314,25 @@ Molecular Epidemiology\" (SCRIME).  The main focus is on SNP data, but most of
 the functions can also be applied to other types of categorical data.")
     (license license:gpl2)))
 
+(define-public r-pbmcapply
+  (package
+    (name "r-pbmcapply")
+    (version "1.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "pbmcapply" version))
+       (sha256
+        (base32
+         "0i58gcqpnbyvc448qfgm45b7rpbmrnagsvk1h1hsqchbbicfslnz"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/kvnkuang/pbmcapply")
+    (synopsis "Track the progress of apply procedures with a progress bar")
+    (description
+     "This light-weight package helps you track and visualize the progress of
+parallel versions of vectorized R functions of the @code{mc*apply} family.")
+    (license license:expat)))
+
 (define-public r-blme
   (package
     (name "r-blme")