summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorpinoaffe <pinoaffe@airmail.cc>2022-02-06 23:33:34 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-06 23:33:34 +0100
commit4255292154c93953f47d66d7c8769be5fb87809d (patch)
treeeeb3d27a586f6f0c5b323c83e6085ff8abf0409e /gnu
parent5fcaee669e0a64496415dc85a0fff086c814d091 (diff)
downloadguix-4255292154c93953f47d66d7c8769be5fb87809d.tar.gz
gnu: Add emacs-apache-mode.
* gnu/packages/emacs-xyz.scm (emacs-apache-mode): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dc18671c46..827cc284e9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4263,6 +4263,29 @@ at the current line number or active region.  @code{git-link-commit} returns
 the URL for a commit.  URLs are added to the kill ring.")
     (license license:gpl3+)))
 
+(define-public emacs-apache-mode
+  (package
+    (name "emacs-apache-mode")
+    (version "2.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emacs-php/apache-mode")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1grs2x51k8pa6sgfa82s5pwwdfv7zw46ccw0zvd2rvzbhpq21p2z"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/emacs-php/apache-mode")
+    (synopsis
+     "Syntax highlighting and indentation support for Apache config files")
+    (description
+     "This package provides @code{apache-mode}, an Emacs major mode for Apache
+configuration files which provides syntax highlighting and indentation rules.
+This mode supports Apache HTTP Server 2.4 and major modules.")
+    (license license:gpl2+)))
+
 (define-public emacs-apheleia
   (package
     (name "emacs-apheleia")