summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-21 17:08:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-21 17:19:39 +0300
commit5506b841d18fa415321c22b7e2b7eec9f6ce50d9 (patch)
tree1a3ac07f62651fb82696fedfc9c4bd40da500264 /gnu
parent0b1cf40dce8e2f2d8651a2a2dc00cfb7026c8014 (diff)
downloadguix-5506b841d18fa415321c22b7e2b7eec9f6ce50d9.tar.gz
gnu: mlt: Don't hardcode gcc value.
* gnu/packages/video.scm (mlt)[arguments]: Adjust make-flags to use
cc-for-target, cxx-for-target.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 444eee849e..fbc468eab7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2998,7 +2998,8 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
-       #:make-flags '("CC=gcc" "CXX=g++")
+       #:make-flags '(,(string-append "CC=" (cc-for-target))
+                      ,(string-append "CXX=" (cxx-for-target)))
        #:configure-flags
        (list "--enable-gpl3"
              "--enable-gpl")