summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-02 15:47:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-03 17:53:41 +0200
commit5bee6bf409dd36b0671ff59bac09d7ad4aa9e09e (patch)
treee87847e93105d290e57da6fd2b50b014655167e7 /gnu
parentdd4b7476ec2c8c1d790f1366173a15bd6042eeee (diff)
downloadguix-5bee6bf409dd36b0671ff59bac09d7ad4aa9e09e.tar.gz
gnu: Add r-glue.
* gnu/packages/cran.scm (r-glue): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9ebfbbed2d..61c6496022 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -42,3 +42,23 @@ including RGB, HSV, HLS, CIEXYZ, CIELUV, HCL (polar CIELUV), CIELAB and polar
 CIELAB.  Qualitative, sequential, and diverging color palettes based on HCL
 colors are provided.")
     (license license:bsd-3)))
+
+(define-public r-glue
+  (package
+    (name "r-glue")
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "glue" version))
+       (sha256
+        (base32
+         "01awmqby7rwzhzr51m7d87wqibx7ggl6xair8fi3z3q1hkyyv7ih"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/tidyverse/glue")
+    (synopsis "Interpreted string literals")
+    (description
+     "This package provides an implementation of interpreted string literals,
+inspired by Python's Literal String Interpolation (PEP-0498) and
+Docstrings (PEP-0257) and Julia's Triple-Quoted String Literals.")
+    (license license:expat)))