summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-24 12:14:21 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:06 -0400
commit695d2a3326cb45b0097b9d457e15c2b31e6aff40 (patch)
treecb308a987b169c61fb72db9cb529084bb17d89b1 /gnu
parent2cdfaa026369d0dfc5760423ecffe27deb97c2d5 (diff)
downloadguix-695d2a3326cb45b0097b9d457e15c2b31e6aff40.tar.gz
gnu: go-github-com-prometheus-common-model: Update to 0.4.1.
* gnu/packages/syncthing.scm (go-github-com-prometheus-common-model):
Update to 0.4.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/syncthing.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 1f10c02555..c89687b864 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -974,20 +974,18 @@ Prometheus metrics.")
       (license asl2.0))))
 
 (define-public go-github-com-prometheus-common-model
-  (let ((commit "2e54d0b93cba2fd133edc32211dcc32c06ef72ca")
-        (revision "0"))
     (package
       (name "go-github-com-prometheus-common-model")
-      (version (git-version "0.0.0" revision commit))
+      (version "0.4.1")
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
                        (url "https://github.com/prometheus/common.git")
-                       (commit commit)))
+                       (commit (string-append "v" version))))
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "14kn5w7imcxxlfdqxl21fsnlf1ms7200g3ldy29hwamldv8qlm7j"))))
+                  "0sf4sjdckblz1hqdfvripk3zyp8xq89w7q75kbsyg4c078af896s"))))
       (build-system go-build-system)
       (arguments
        '(#:import-path "github.com/prometheus/common/model"
@@ -996,7 +994,7 @@ Prometheus metrics.")
       (description "This package provides a component of the Go Prometheus
 implementation.")
       (home-page "https://github.com/prometheus/common")
-      (license asl2.0))))
+      (license asl2.0)))
 
 (define-public go-github-com-prometheus-procfs
     (package