summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorr0man <roman@burningswell.com>2023-01-22 13:00:53 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-11 21:51:35 +0100
commit6bf7144c79fad7a88780a672b96e677d0907bcc9 (patch)
treef22dab4803e3722f4a8844c916082ddf2f98f998 /gnu
parentb98718fc3f33f57fdf69c4f01e74f7d1dd6ddaca (diff)
downloadguix-6bf7144c79fad7a88780a672b96e677d0907bcc9.tar.gz
gnu: Add lzfse.
* gnu/packages/compression.scm (lzfse): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 653bde38d8..42766a707a 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -2807,6 +2807,27 @@ serializations such as ASN.1 and MessagePack.")
     (license license:expat)
     (home-page "https://github.com/PJK/libcbor")))
 
+(define-public lzfse
+  (package
+    (name "lzfse")
+    (version "1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/lzfse/lzfse")
+             (commit (string-append "lzfse-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1mfh6y6vpvxsdwmqmfbkqkwvxc0pz2dqqc72c6fk9sbsrxxaghd5"))))
+    (build-system cmake-build-system)
+    (home-page "https://github.com/lzfse/lzfse")
+    (synopsis "LZFSE compression library and command line tool")
+    (description "LZFSE is a Lempel-Ziv style data compression algorithm using
+Finite State Entropy coding.  It targets similar compression rates at higher
+compression and decompression speed compared to Deflate using Zlib.")
+    (license license:bsd-3)))
+
 (define-public fcrackzip
   (package
     (name "fcrackzip")