summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2023-01-06 16:06:47 -0500
committerDavid Thompson <dthompson2@worcester.edu>2023-01-08 13:25:34 -0500
commit6ca59eec9ad8b63a5cbc12cb42ab8b1d6b08f116 (patch)
tree063940354e21ac9c5ec9531cb670adc585f65f67 /gnu
parent8cca1a35bc42cddb7e0586062d192197520042d5 (diff)
downloadguix-6ca59eec9ad8b63a5cbc12cb42ab8b1d6b08f116.tar.gz
gnu: git-annex: Patch 'git-annex webapp' to use hardcoded xdg-open.
* gnu/packages/haskell-apps.scm (git-annex)[arguments]: Add 'patch-webapp'
phase.
[inputs]: Add xdg-utils.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-apps.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index a2405796ca..4ac486eeb6 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -18,6 +18,7 @@
 ;;; Copyright © 2021 EuAndreh <eu@euandre.org>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2022 David Thompson <dthompson2@worcester.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -42,6 +43,7 @@
   #:use-module (guix build-system haskell)
   #:use-module (gnu packages)
   #:use-module (gnu packages curl)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages haskell)
   #:use-module (gnu packages haskell-check)
@@ -327,6 +329,13 @@ to @code{cabal repl}).")
              (copy-file "Utility/Shell.hs" "/tmp/Shell.hs")
              (substitute* "Utility/Shell.hs"
                (("/bin/sh") (which "sh")))))
+         (add-before 'configure 'patch-webapp
+           (lambda _
+             ;; Replace loose references to xdg-open so that 'git annex
+             ;; webapp' runs without making the user also install xdg-utils.
+             (substitute* '("Assistant/WebApp/DashBoard.hs"
+                            "Utility/WebApp.hs")
+               (("xdg-open") (which "xdg-open")))))
          (add-before 'configure 'factor-setup
            (lambda _
              ;; Factor out necessary build logic from the provided
@@ -471,7 +480,8 @@ to @code{cabal repl}).")
            ghc-yesod-core
            ghc-yesod-form
            ghc-yesod-static
-           rsync))
+           rsync
+           xdg-utils))
     (propagated-inputs
      (list git))
     (native-inputs