summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-01-20 20:18:55 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2020-01-23 09:00:49 +0100
commit6e5fc6c7efe0d3a8465e419bfd2883c64ec0e509 (patch)
treeb117c3b1871e4e87a5add5463ec414db924ebe53 /gnu
parent7357b3d7a52eb5db1674012c50d308d792741c48 (diff)
downloadguix-6e5fc6c7efe0d3a8465e419bfd2883c64ec0e509.tar.gz
gnu: mes: Update to 0.22.
* gnu/packages/mes.scm (mes): Update to 0.22.  Remove store name patch.  Add
MES_PREFIX to native-search-paths.
* gnu/packages/patches/mes-remove-store-name.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/mes.scm (mes-rb5): Depend on gzip instead of xz; this enables
unpacking the now unpatched mes source.  Update to check bin/mes-mescc-0.21.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/mes.scm21
-rw-r--r--gnu/packages/patches/mes-remove-store-name.patch121
3 files changed, 13 insertions, 130 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 46d040c507..563c98b122 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1166,7 +1166,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/mcrypt-CVE-2012-4426.patch			\
   %D%/packages/patches/mcrypt-CVE-2012-4527.patch			\
   %D%/packages/patches/libmemcached-build-with-gcc7.patch	\
-  %D%/packages/patches/mes-remove-store-name.patch		\
   %D%/packages/patches/mesa-skip-disk-cache-test.patch		\
   %D%/packages/patches/mescc-tools-boot.patch			\
   %D%/packages/patches/meson-for-build-rpath.patch		\
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 5d85c5ff51..347aef0a8c 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018, 2019 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2017, 2018, 2019, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
@@ -143,15 +143,14 @@ Guile.")
 (define-public mes
   (package
     (inherit mes-0.19)
-    (version "0.21")
+    (version "0.22")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/mes/"
                                   "mes-" version ".tar.gz"))
-              (patches (search-patches "mes-remove-store-name.patch"))
               (sha256
                (base32
-                "104qxngxyl7pql8vqrnli3wfyx0ayfaqg8gjfhmk4qzrafs46slm"))))
+                "0p1jsrrmcbc0zrvbvnjbb6iyxr0in71km293q8qj6gnar6bw09av"))))
     (propagated-inputs
      `(("mescc-tools" ,mescc-tools)
        ("nyacc" ,nyacc)))
@@ -161,7 +160,11 @@ Guile.")
             (files '("include")))
            (search-path-specification
             (variable "LIBRARY_PATH")
-            (files '("lib")))))))
+            (files '("lib")))
+           (search-path-specification
+            (variable "MES_PREFIX")
+            (separator #f)
+            (files '("")))))))
 
 (define-public mes-rb5
   ;; This is the Reproducible-Builds summit 5's Mes, also built on Debian
@@ -176,6 +179,7 @@ Guile.")
        ("coreutils" ,coreutils)
        ("grep" ,grep)
        ("guile" ,guile-2.2)
+       ("gzip" ,gzip)
        ("libc" ,glibc)
        ("locales" ,glibc-utf8-locales)
        ("make" ,gnu-make)
@@ -183,8 +187,7 @@ Guile.")
        ("mescc-tools" ,mescc-tools)
        ("nyacc" ,nyacc)
        ("sed" ,sed)
-       ("tar" ,tar)
-       ("xz" ,xz)))
+       ("tar" ,tar)))
     (supported-systems '("i686-linux"))
     (arguments
      `(#:implicit-inputs? #f
@@ -215,10 +218,12 @@ Guile.")
              (invoke "sh" "bootstrap.sh")))
          (replace 'check
            (lambda _
+             (copy-file "bin/mes-mescc" "bin/mes-mescc-0.21")
+             (system* "sed" "-i" "s/0\\.22/0\\.21/" "bin/mes-mescc-0.21")
              (let ((sha256sum
                     (read-delimited
                      " "
-                     (open-pipe* OPEN_READ "sha256sum" "src/mes"))))
+                     (open-pipe* OPEN_READ "sha256sum" "bin/mes-mescc-0.21"))))
                (unless
                    (equal?
                     sha256sum
diff --git a/gnu/packages/patches/mes-remove-store-name.patch b/gnu/packages/patches/mes-remove-store-name.patch
deleted file mode 100644
index ad055c51f2..0000000000
--- a/gnu/packages/patches/mes-remove-store-name.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-From d8f361705325cf91fc6c2ec84f281cdcd6bfa8b1 Mon Sep 17 00:00:00 2001
-From: Jan Nieuwenhuizen <janneke@gnu.org>
-Date: Tue, 3 Dec 2019 21:23:24 +0100
-Subject: [PATCH] core: Remove MES_PKGDATADIR.
-
-* configure: Do not add MES_PKGDATADIR to config.h.
-* configure.sh: Likewise.
-* simple.sh: Likewise.
-* src/mes.c (open_boot): Do not use MES_PKGDATADIR; rely on
-MES_PREFIX or cwd.
----
- configure    |  1 -
- configure.sh |  1 -
- simple.sh    |  2 --
- src/mes.c    | 13 -------------
- 4 files changed, 17 deletions(-)
-
-diff --git a/configure b/configure
-index 8edb2ce7b..12d8323f2 100755
---- a/configure
-+++ b/configure
-@@ -666,7 +666,6 @@ See \"Porting GNU Mes\" in the manual, or try --with-courage\n" mes-system)
- "))
-               (display (string-append "
- #define MES_VERSION \"" VERSION "\"
--#define MES_PKGDATADIR \"" pkgdatadir "\"
- ")))))
-         (substitute (string-append srcdest "build-aux/config.make.in") pairs #:target ".config.make"))
- 
-diff --git a/configure.sh b/configure.sh
-index 947ddd851..0139cbc36 100755
---- a/configure.sh
-+++ b/configure.sh
-@@ -244,7 +244,6 @@ EOF
- fi
- cat >> include/mes/config.h <<EOF
- #define MES_VERSION "$VERSION"
--#define MES_PKGDATADIR "$pkgdatadir"
- EOF
- 
- cat <<EOF
-diff --git a/simple.sh b/simple.sh
-index db6950354..b54398a59 100755
---- a/simple.sh
-+++ b/simple.sh
-@@ -33,7 +33,6 @@ mes_bits=64
- cat > include/mes/config.h <<EOF
- #define SYSTEM_LIBC 1
- #define MES_VERSION "git"
--#define MES_PKGDATADIR "/usr/local/share/mes"
- EOF
- 
- ## Build ##
-@@ -126,7 +125,6 @@ mes_cpu=x86_64
- cat > include/mes/config.h <<EOF
- // #define SYSTEM_LIBC 0
- #define MES_VERSION "git"
--#define MES_PKGDATADIR "/usr/local/share/mes"
- EOF
- 
- ## Build ##
-diff --git a/src/mes.c b/src/mes.c
-index d9760fad6..a5e7f2b69 100644
---- a/src/mes.c
-+++ b/src/mes.c
-@@ -1775,12 +1775,6 @@ open_boot ()
-   char boot[1024];
-   char file_name[1024];
-   strcpy (g_datadir, ".");
--  if (g_debug > 1)
--    {
--      eputs (";;; pkgdatadir=");
--      eputs (MES_PKGDATADIR);
--      eputs ("\n");
--    }
-   if (getenv ("MES_BOOT"))
-     strcpy (boot, getenv ("MES_BOOT"));
-   else
-@@ -1801,13 +1795,6 @@ open_boot ()
-           __stdin = try_open_boot (file_name, boot, "MES_PREFIX/share/mes");
-         }
-     }
--  if (__stdin < 0)
--    {
--      strcpy (g_datadir, MES_PKGDATADIR);
--      strcpy (file_name, g_datadir);
--      strcpy (file_name + strlen (file_name), "/module/mes/");
--      __stdin = try_open_boot (file_name, boot, "pkgdatadir");
--    }
-   if (__stdin < 0)
-     {
-       g_datadir[0] = 0;
--- 
-2.24.0
-
-commit 2f6fab05b3f09df02aba70c3e21d5fedb45dc567
-Author: Jan Nieuwenhuizen <janneke@gnu.org>
-Date:   Sun Nov 24 23:12:29 2019 +0100
-
-    core: Throw instead of segfault on non-existing input file.  WIP.
-    
-    Reported by theruran.
-    
-    * src/posix.c (open_input_file): Call error instead of failing silently.
-
-diff --git a/src/posix.c b/src/posix.c
-index 7ba2e9915..fd753232d 100644
---- a/src/posix.c
-+++ b/src/posix.c
-@@ -188,7 +188,10 @@ current_input_port ()
- SCM
- open_input_file (SCM file_name)
- {
--  return MAKE_NUMBER (mes_open (CSTRING (file_name), O_RDONLY, 0));
-+  int filedes = mes_open (CSTRING (file_name), O_RDONLY, 0);
-+  if (filedes == -1)
-+    error (cell_symbol_system_error, cons (MAKE_STRING0 ("No such file or directory"), file_name));
-+  return MAKE_NUMBER (filedes);
- }
- 
- SCM