summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-05 15:40:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-17 11:04:45 +0200
commit7b9769b04d66c3121c5295676f4d5ae686c96936 (patch)
treeed6d32afb7ee34c71edfda06e0cf82f62b01059c /gnu
parent655684468e28f841b432ac3f34751e29c6721953 (diff)
downloadguix-7b9769b04d66c3121c5295676f4d5ae686c96936.tar.gz
gnu: Add emacs-znc.
* gnu/packages/emacs.scm (emacs-znc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7a67b03f06..d2e306b248 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1372,6 +1372,26 @@ keep pressing the key until it selects what you want.  There's also
 column by drawing a thin line down the length of the editing window.")
     (license license:gpl3+)))
 
+(define-public emacs-znc
+  (package
+    (name "emacs-znc")
+    (version "0.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://marmalade-repo.org/packages/znc-"
+                           version ".el"))
+       (sha256
+        (base32
+         "1d8lqvybgyazin5z0g1c4l3rg1vzrrvf0saqs53jr1zcdg0lianh"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/sshirokov/ZNC.el")
+    (synopsis "Make ERC and ZNC get along better")
+    (description
+     "This is a thin wrapper around @code{erc} that enables one to use the ZNC
+IRC bouncer with ERC.")
+    (license license:expat)))
+
 (define-public emacs-ob-ipython
   (package
     (name "emacs-ob-ipython")