summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-21 12:42:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-21 12:42:36 +0200
commit7cfc226d1e8a3393559efe2f95fb7d8c50e534fc (patch)
treec0b0a41911f124b7731f4613b28403797651ac2b /gnu
parentd3bc56da0475bc643ccb065483c53c6d28cf8e39 (diff)
downloadguix-7cfc226d1e8a3393559efe2f95fb7d8c50e534fc.tar.gz
gnu: luakit: Further improve style.
This is a followup to d3bc56da0475bc643ccb065483c53c6d28cf8e39.

* gnu/packages/web-browsers.scm (luakit)[arguments]<#:phases>: Remove
unnecessary INPUTS key.
[inputs]: Sort alphabetically.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web-browsers.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 0730d5b19a..7b06e54cdf 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -246,7 +246,7 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
               (setenv "VERSION_FROM_GIT" #$version)))
           (delete 'configure)
           (add-after 'install 'wrap
-            (lambda* (#:key inputs #:allow-other-keys)
+            (lambda _
               (wrap-program (string-append #$output "/bin/luakit")
                 `("LUA_CPATH" prefix
                   (,(string-append #$(this-package-input "lua5.1-filesystem")
@@ -256,14 +256,14 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
     (native-inputs
      (list pkg-config))
     (inputs
-     (list lua-5.1
-           gtk+
+     (list glib-networking
            gsettings-desktop-schemas
-           glib-networking
+           gtk+
+           lua-5.1
            lua5.1-filesystem
            luajit
-           webkitgtk-with-libsoup2
-           sqlite))
+           sqlite
+           webkitgtk-with-libsoup2))
     (synopsis "Fast, lightweight, and simple browser based on WebKit")
     (description "Luakit is a fast, lightweight, and simple to use
 micro-browser framework extensible by Lua using the WebKit web content engine