summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-19 00:04:49 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-03 12:30:45 +0100
commit7f53aa7aa8495540e59fe235b9c490470b9501b6 (patch)
treebd31c3c75b89d17c2436f0091d43be928ef290e5 /gnu
parenta6fc3bc1630ffb2a44be8ddffcc402cefb394278 (diff)
downloadguix-7f53aa7aa8495540e59fe235b9c490470b9501b6.tar.gz
gnu: Add julia-arnoldimethod.
* gnu/packages/julia-xyz.scm (julia-arnoldimethod): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index df9d6a5daa..c2a4ba1520 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -147,6 +147,42 @@ ANSI escape codes to another format.")
 provides functions to run a few automatable checks for Julia packages.")
     (license license:expat)))
 
+(define-public julia-arnoldimethod
+  (package
+    (name "julia-arnoldimethod")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaLinearAlgebra/ArnoldiMethod.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1gs7pikgdg436srxxfywpnp12ay1mf45f7z80wym92rfrjzakwh2"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     (list julia-genericschur julia-staticarrays))
+    (home-page "https://github.com/JuliaLinearAlgebra/ArnoldiMethod.jl")
+    (synopsis "Implicitly Restarted Arnoldi Method, natively in Julia")
+    (description
+     "@code{ArnoldiMethod.jl} provides an iterative method to find a few
+approximate solutions to the eigenvalue problem in standard form with main
+goals:
+
+@itemize
+@item Having a native Julia implementation of the @code{eigs} function that
+performs as well as ARPACK.  With native we mean that its implementation should
+be generic and support any number type.  Currently the partialschur function
+does not depend on LAPACK, and removing the last remnants of direct calls to
+BLAS is in the pipeline.
+
+@item Removing the dependency of the Julia language on ARPACK.  This goal was
+already achieved before the package was stable enough, since ARPACK moved to a
+separate repository @code{Arpack.jl}.
+@end itemize")
+    (license license:expat)))
+
 (define-public julia-arrayinterface
   (package
     (name "julia-arrayinterface")