summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 11:45:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:45:37 +0200
commit87682c88c858a2b545b347ad951524f14bd98633 (patch)
tree407a2f3774f4c3cde03c00b2aa4558ab6410668d /gnu
parent4638c52e32f15610a65c3dfc5e6833be088646b9 (diff)
downloadguix-87682c88c858a2b545b347ad951524f14bd98633.tar.gz
gnu: Add r-mmwrweek.
* gnu/packages/cran.scm (r-mmwrweek): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a8164c8a98..a66ec87adc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31170,3 +31170,26 @@ concentric rings and radial lines emanating from a central point.")
      "Create new analysis setups and deal with results of Zonation
 conservation prioritization software.")
     (license license:bsd-2)))
+
+(define-public r-mmwrweek
+  (package
+    (name "r-mmwrweek")
+    (version "0.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "MMWRweek" version))
+       (sha256
+        (base32
+         "1l1ks44v52iggw9nhs56lfj6804yab5b17k8fzrc6h1kvj3vda0s"))))
+    (properties `((upstream-name . "MMWRweek")))
+    (build-system r-build-system)
+    (home-page "http://wwwn.cdc.gov/nndss/document/MMWR_Week_overview.pdf")
+    (synopsis "Convert dates to MMWR day, week, and year")
+    (description
+     "The first day of any MMWR week is Sunday.  MMWR week numbering is
+sequential beginning with 1 and incrementing with each week to a maximum of 52
+or 53.  MMWR week #1 of an MMWR year is the first week of the year that has at
+least four days in the calendar year.  This package provides functionality to
+convert dates to MMWR day, week, and year and the reverse.")
+    (license license:gpl2+)))