summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-18 17:00:48 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-18 17:01:21 +0000
commit9d0c5f18e7c763ee8815f49865d057c2a65ff313 (patch)
treec40bd0e8c22fd88399ff7774d10f8b44e35cf297 /gnu
parent3b1cf6ab5ea1c1e47d02372148529595990176eb (diff)
downloadguix-9d0c5f18e7c763ee8815f49865d057c2a65ff313.tar.gz
gnu: python-typer: Run tests conditionally.
* gnu/packages/python-xyz.scm (python-typer)[arguments]: Only run tests when
TESTS? is #true.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3115d367b2..1f086edc0f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20863,22 +20863,23 @@ based on the CPython 2.7 and 3.7 parsers.")
                (("\"bash\"") (string-append "\"" (which "bash") "\""))
                (("\"/bin/bash\"") (string-append "\"" (which "bash") "\"")))))
          (replace 'check
-           (lambda _
-             (setenv "HOME" "/tmp") ; some tests need it
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (setenv "HOME" "/tmp") ; some tests need it
 
-             ;; This is for completion tests
-             (with-output-to-file "/tmp/.bashrc" (lambda _ (display "# dummy")))
+               ;; This is for completion tests
+               (with-output-to-file "/tmp/.bashrc" (lambda _ (display "# dummy")))
 
-             (setenv "GUIX_PYTHONPATH"
-                     (string-append (getcwd) ":"
-                                    (getenv "GUIX_PYTHONPATH")))
-             (let ((disabled-tests (list "test_show_completion"
-                                         "test_install_completion")))
-               (invoke "python" "-m" "pytest" "tests/"
-                       "-k"
-                       (string-append "not "
-                                      (string-join disabled-tests
-                                                   " and not ")))))))))
+               (setenv "GUIX_PYTHONPATH"
+                       (string-append (getcwd) ":"
+                                      (getenv "GUIX_PYTHONPATH")))
+               (let ((disabled-tests (list "test_show_completion"
+                                           "test_install_completion")))
+                 (invoke "python" "-m" "pytest" "tests/"
+                         "-k"
+                         (string-append "not "
+                                        (string-join disabled-tests
+                                                     " and not "))))))))))
     (propagated-inputs
      `(("python-click" ,python-click)))
     (native-inputs