summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-18 16:58:44 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-18 17:01:20 +0000
commit9e76a5b7cb84534bcda7507773b681f13df11698 (patch)
tree9445dd31fbd34e8bc4bd41cd21c00cfe926a3f06 /gnu
parent28b92acf6b180f186dddd29fec630d9c140458d1 (diff)
downloadguix-9e76a5b7cb84534bcda7507773b681f13df11698.tar.gz
gnu: python-typer: Run more tests.
* gnu/packages/python-xyz.scm (python-typer)[arguments]: Delete phase
'disable-failing-tests; disable only test_show_completion and
test_install_completion in 'check phase; add phase 'patch-shell-reference.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 603ef2a7f0..e9ec5ff059 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20855,30 +20855,30 @@ based on the CPython 2.7 and 3.7 parsers.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-before 'check 'disable-failing-tests
+         ;; Unfortunately, this doesn't seem to be enough to fix these two
+         ;; tests, but we'll patch this anyway.
+         (add-after 'unpack 'patch-shell-reference
            (lambda _
              (substitute* "tests/test_completion/test_completion.py"
-               (("def test_show_completion")
-                "def _test_show_completion")
-               (("def test_install_completion")
-                "def _test_install_completion"))
-             (substitute* "tests/test_completion/test_completion_install.py"
-               (("def test_completion_install_bash")
-                "def _test_completion_install_bash")
-               (("def test_completion_install_zsh")
-                "def _test_completion_install_zsh")
-               (("def test_completion_install_fish")
-                "def _test_completion_install_fish")
-               (("def test_completion_install_powershell")
-                "def _test_completion_install_powershell"))
-             #t))
+               (("\"bash\"") (string-append "\"" (which "bash") "\""))
+               (("\"/bin/bash\"") (string-append "\"" (which "bash") "\"")))))
          (replace 'check
            (lambda _
+             (setenv "HOME" "/tmp") ; some tests need it
+
+             ;; This is for completion tests
+             (with-output-to-file "/tmp/.bashrc" (lambda _ (display "# dummy")))
+
              (setenv "PYTHONPATH"
                      (string-append (getcwd) ":"
                                     (getenv "PYTHONPATH")))
-             (invoke "python" "-m" "pytest" "tests/")
-             #t)))))
+             (let ((disabled-tests (list "test_show_completion"
+                                         "test_install_completion")))
+               (invoke "python" "-m" "pytest" "tests/"
+                       "-k"
+                       (string-append "not "
+                                      (string-join disabled-tests
+                                                   " and not ")))))))))
     (propagated-inputs
      `(("python-click" ,python-click)))
     (native-inputs