summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-05-06 15:25:11 -0300
committerVinicius Monego <monego@posteo.net>2023-05-14 11:10:17 -0300
commitbe18d943ba6f0a619accfd33054cf3ad09eb6f69 (patch)
tree829dcf0beee27b7ac0e9f2c2a292d9637ed024e7 /gnu
parenteb7312401ea89e634f8d686db71bacda58b2755f (diff)
downloadguix-be18d943ba6f0a619accfd33054cf3ad09eb6f69.tar.gz
gnu: python-opentsne: Update to 0.7.1.
* gnu/packages/machine-learning.scm (python-opentsne): Update to 0.7.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index a5da314688..b8793fb31a 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1361,7 +1361,7 @@ for k-neighbor-graph construction and approximate nearest neighbor search.")
 (define-public python-opentsne
   (package
     (name "python-opentsne")
-    (version "0.6.1")
+    (version "0.7.1")
     (source
      (origin
        (method git-fetch) ; no tests in PyPI release
@@ -1370,27 +1370,23 @@ for k-neighbor-graph construction and approximate nearest neighbor search.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "124nid27lfq1ipfjd2gkynqcmb4khisjb4r05jv42ckfkk4dbsxs"))))
+        (base32 "12wp98mh67v6v683yi7wbv8zhpafrfz21z349bww4wgi2q7bl3il"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          ;; Benchmarks require the 'macosko2015' data files.
          (add-after 'unpack 'delete-benchmark
-           (lambda _
-             (delete-file-recursively "benchmarks")))
+           (lambda _ (delete-file-recursively "benchmarks")))
          (add-after 'unpack 'skip-test
            (lambda _ ;; TODO: figure out why this test fails.
              (substitute* "tests/test_correctness.py"
                (("def test_iris\\(self\\)") "def _test_iris(self)"))))
          ;; Numba needs a writable dir to cache functions.
          (add-before 'check 'set-numba-cache-dir
-           (lambda _
-             (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
-    (native-inputs
-     (list python-cython))
-    (inputs
-     (list fftw))
+           (lambda _ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+    (native-inputs (list python-cython))
+    (inputs (list fftw))
     (propagated-inputs
      (list python-numpy python-pynndescent python-scikit-learn
            python-scipy))