summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-01-04 23:47:44 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-01-10 15:15:32 +0200
commitccc13b9e0a365ed7ffcd2fb3e1f65492a8bc8572 (patch)
tree91fcc640cccd11225d063917a7625140bf345f8c /gnu
parent3f0b76bdcc19cbb5cb577c86b9e4119daa4008fa (diff)
downloadguix-ccc13b9e0a365ed7ffcd2fb3e1f65492a8bc8572.tar.gz
gnu: Add julia-biogenerics.
* gnu/packages/julia-xyz.scm (julia-biogenerics): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 897c189afb..515720d0c7 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -333,6 +333,32 @@ code easy by supplying a framework for writing and running groups of
 benchmarks as well as comparing benchmark results.")
     (license license:expat)))
 
+(define-public julia-biogenerics
+  ;; No upstream release
+  (let ((commit "a75abaf459250e2b5e22b4d9adf25fd36d2acab6")
+        (revision "1"))
+    (package
+      (name "julia-biogenerics")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/BioJulia/BioGenerics.jl")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "17d222vi9nssjwr5l349fss7jnglnjimp1z62kmfmxa4fsn8lk8l"))))
+      (build-system julia-build-system)
+      (inputs
+       (list julia-transcodingstreams))
+      (home-page "https://github.com/BioJulia/BioGenerics.jl")
+      (synopsis "Generic methods used by BioJulia packages")
+      (description "This package provides generic methods and modules used in
+many of the other BioJulia packages.  This package defines IO, exceptions, and
+other types or methods used by other BioJulia packages.")
+      (license license:expat))))
+
 (define-public julia-blockarrays
   (package
     (name "julia-blockarrays")