summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-01-13 09:24:15 +0800
committer宋文武 <iyzsong@gmail.com>2016-01-16 08:18:37 +0800
commite224b7d0bdfc58e251ba57f03c1ff74c7b4c2c62 (patch)
treeb9bc05fc0d4dcd7769221e87167cf8bceb0d0661 /gnu
parent4ecdeef8aed9e0dc0e338c205773f11249dcb238 (diff)
downloadguix-e224b7d0bdfc58e251ba57f03c1ff74c7b4c2c62.tar.gz
gnu: Add python-rply.
* gnu/packages/python.scm (python-rply, python2-rply): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 84e93d9ab3..ee6da2cdbf 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7032,3 +7032,28 @@ Abstract Syntax Tree.")
 
 (define-public python2-astor
   (package-with-python2 python-astor))
+
+(define-public python-rply
+  (package
+    (name "python-rply")
+    (version "0.7.4")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "rply" version))
+              (sha256
+               (base32
+                "12rp1d9ba7nvd5rhaxi6xzx1rm67r1k1ylsrkzhpwnphqpb06cvj"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-appdirs" ,python-appdirs)
+       ("python-setuptools" ,python-setuptools)))
+    (home-page "https://github.com/alex/rply")
+    (synopsis "Parser generator for Python")
+    (description
+     "This package provides a pure Python based parser generator, that also
+works with RPython.  It is a more-or-less direct port of David Bazzley's PLY,
+with a new public API, and RPython support.")
+    (license bsd-3)))
+
+(define-public python2-rply
+  (package-with-python2 python-rply))