summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-18 12:38:58 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-18 12:38:58 +0100
commitffcf4ea9abbbc35fefbe4a491e1e5eac1c7c0002 (patch)
tree5202fe776dbeead8cf5ad705faec4a85996db44c /gnu
parent1db174a3addcdb6bd6cc94704a435b1d4b75b726 (diff)
downloadguix-ffcf4ea9abbbc35fefbe4a491e1e5eac1c7c0002.tar.gz
gnu: qgpgme: Depend on a newer GnuPG.
This addresses a test failure in 'testSymmetricEncryptDecrypt':

  FAIL!  : EncryptionTest::testSymmetricEncryptDecrypt() 'QString::fromUtf8(plainText) == QStringLiteral("Hello symmetric World")' returned FALSE. ()
     Loc: [t-encrypt.cpp(188)]

The failure was apparently due to gpg asking for a passphrase for
symmetric decryption.

* gnu/packages/gnupg.scm (gnupg-2.2.32): New variable.
(qgpgme)[native-inputs]: Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnupg.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 5bd1c0450e..6232897060 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -348,6 +348,18 @@ libskba (working with X.509 certificates and CMS data).")
     (properties '((ftp-server . "ftp.gnupg.org")
                   (ftp-directory . "/gcrypt/gnupg")))))
 
+(define-public gnupg-2.2.32
+  (package
+    (inherit gnupg)
+    (version "2.2.32")
+    (source (origin
+              (inherit (package-source gnupg))
+              (uri (string-append "mirror://gnupg/gnupg/gnupg-" version
+                                  ".tar.bz2"))
+              (sha256
+               (base32
+                "0506gv54z10c96z5821z9p0ksibk1pfilsmag39ffqrcz0sinmxj"))))))
+
 (define-public gnupg-1
   (package (inherit gnupg)
     (version "1.4.23")
@@ -426,8 +438,12 @@ and every application benefits from this.")
              (chdir "lang/qt")
              #t)))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ,@(package-native-inputs gpgme)))
+     ;; Use GnuPG 2.2.32.  With 2.2.30, 'testSymmetricEncryptDecrypt' in
+     ;; t-encrypt.cpp fails because 'gpg' wrongfully ask for a passphrase do
+     ;; decrypt the cypher text.
+     (modify-inputs (package-native-inputs gpgme)
+       (replace "gnupg" gnupg-2.2.32)
+       (prepend pkg-config)))
     (inputs
      `(("gpgme" ,gpgme)
        ("qtbase" ,qtbase-5)