summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2017-01-28 12:30:50 +0800
committer宋文武 <iyzsong@member.fsf.org>2017-01-28 12:30:50 +0800
commit0050876bcf5c44340322bd3a7ef3418a50766644 (patch)
tree40510448d35ca53093504a1f17f10745ea7a81ea /gnu
parent736cfc10f0891f1626a3d78c7c304ba6a42ba93b (diff)
downloadguix-0050876bcf5c44340322bd3a7ef3418a50766644.tar.gz
gnu: assword: Wrap with the GObject typelib of GTK+.
Fixes <https://debbugs.gnu.org/25457>.

* gnu/packages/password-utils.scm (assword)[inputs]: Add 'gtk+'.
[arguments]: Add 'wrap-assword' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/password-utils.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index feb6848e09..0a3b4b64e7 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -36,6 +36,7 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages man)
@@ -240,6 +241,15 @@ random passwords that pass the checks.")
        #:tests? #f
        #:phases
        (modify-phases %standard-phases
+         (add-after 'install 'wrap-assword
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((prog            (string-append
+                                     (assoc-ref outputs "out")
+                                     "/bin/assword"))
+                   (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+               (wrap-program prog
+                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))
+               #t)))
          (add-after 'install 'manpage
            (lambda* (#:key outputs #:allow-other-keys)
              (and
@@ -255,7 +265,8 @@ random passwords that pass the checks.")
     (native-inputs
      `(("txt2man" ,txt2man)))
     (inputs
-     `(("python-xdo" ,python-xdo)
+     `(("gtk+" ,gtk+)
+       ("python-xdo" ,python-xdo)
        ("python-gpg" ,python-gpg)
        ("python-pygobject" ,python-pygobject)))
     (propagated-inputs