summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-10-19 10:48:56 +0200
committerRoel Janssen <roel@gnu.org>2016-10-19 10:48:56 +0200
commitc79ad57a8def00a3fbefc7cac1f2306aaa1056bd (patch)
treec4e53699e9512db8634ba738bafaf3540b6cba51 /gnu
parent2acaaee55007ddae404661e9f260ca720cbcda2d (diff)
downloadguix-c79ad57a8def00a3fbefc7cac1f2306aaa1056bd.tar.gz
gnu: Add r-optparse.
* gnu/packages/bioinformatics.scm (r-optparse): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a7e4d0990d..00770e8fbb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5910,6 +5910,29 @@ features like automatically generated help options and usage texts,
 support for default values, positional argument support, etc.")
     (license license:gpl2+)))
 
+(define-public r-optparse
+  (package
+    (name "r-optparse")
+    (version "1.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "optparse" version))
+       (sha256
+        (base32
+         "1g8as89r91xxi5j5azsd6vrfrhg84mnfx2683j7pacdp8s33radw"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-getopt" ,r-getopt)))
+    (home-page
+     "https://github.com/trevorld/optparse")
+    (synopsis "Command line option parser")
+    (description
+     "This package provides a command line parser inspired by Python's
+@code{optparse} library to be used with Rscript to write shebang scripts
+that accept short and long options.")
+    (license license:gpl2+)))
+
 (define-public r-dnacopy
   (package
     (name "r-dnacopy")