summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-10-31 00:24:04 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-11-15 22:42:35 -0500
commit03592a6f882f5b4309f77c3dc3e65559d7b7cb75 (patch)
tree507e5e38596c8a938c9d1c4c1183406bb675bf04 /gnu
parent30f0d21b407756e88cd960a9678b6af0a1ad80e9 (diff)
downloadguix-03592a6f882f5b4309f77c3dc3e65559d7b7cb75.tar.gz
gnu: emacs-realgud: Patch configure.ac to repair the build.
This fixes https://bugs.gnu.org/33196, a build problem caused by a defective
Elisp snippet in a check in configure.ac.

* gnu/packages/patches/emacs-realgud-fix-configure-ac.patch: Add patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/emacs.scm (emacs-realgud)[source]: Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/emacs.scm6
-rw-r--r--gnu/packages/patches/emacs-realgud-fix-configure-ac.patch27
3 files changed, 34 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 23a6cb34b5..2a90a85a6c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -19,6 +19,7 @@
 # Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
 # Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
 # Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
+# Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 #
 # This file is part of GNU Guix.
 #
@@ -663,6 +664,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/emacs-highlight-stages-add-gexp.patch	\
   %D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch	\
   %D%/packages/patches/emacs-source-date-epoch.patch		\
+  %D%/packages/patches/emacs-realgud-fix-configure-ac.patch	\
   %D%/packages/patches/enlightenment-fix-setuid-path.patch	\
   %D%/packages/patches/erlang-man-path.patch			\
   %D%/packages/patches/eudev-rules-directory.patch		\
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3e32998a9f..ce1add3915 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3659,7 +3659,11 @@ after buffer changes.")
                            version ".tar"))
        (sha256
         (base32
-         "108wgxg7fb4byaiasgvbxv2hq7b00biq9f0mh9hy6vw4160y5w24"))))
+         "108wgxg7fb4byaiasgvbxv2hq7b00biq9f0mh9hy6vw4160y5w24"))
+       (patches
+        ;; Patch awaiting inclusion upstream (see:
+        ;; https://github.com/realgud/realgud/pull/226).
+        (search-patches "emacs-realgud-fix-configure-ac.patch"))))
     (build-system emacs-build-system)
     (arguments
      `(#:tests? #t
diff --git a/gnu/packages/patches/emacs-realgud-fix-configure-ac.patch b/gnu/packages/patches/emacs-realgud-fix-configure-ac.patch
new file mode 100644
index 0000000000..8165857c87
--- /dev/null
+++ b/gnu/packages/patches/emacs-realgud-fix-configure-ac.patch
@@ -0,0 +1,27 @@
+From a293690f29407ac54a218d6d20c2142e1a0319d1 Mon Sep 17 00:00:00 2001
+From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
+Date: Wed, 31 Oct 2018 00:08:34 -0400
+Subject: [PATCH] configure.ac: Fix NO_CHECK_EMACS_PACKAGES elisp.
+
+Remove the extraneous trailing parenthesis.
+---
+ configure.ac | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index de0d932..69bcea7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,8 +25,7 @@ AC_MSG_NOTICE("Checking prerequiste packages")
+ $EMACS -batch -q --no-site-file -eval \
+   '(dolist (package
+          (quote (cl-lib loc-changes load-relative test-simple)))
+-        (require package))
+-   )'
++        (require package))'
+ fi
+ if test $? -ne 0 ; then
+     AC_MSG_ERROR([Can't continue until above error is corrected.])
+-- 
+2.19.0
+