summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-30 03:30:26 -0400
committerLeo Famulari <leo@famulari.name>2017-03-30 03:37:31 -0400
commit06e8d0c8e5179d79bd04afed197b9365d85f1cf7 (patch)
treee247ede99320888b3a8f1a4711d4d2b5f84df0d1 /gnu
parent755c5ba85c03aa2631a6e9f0284fe8d6652938cf (diff)
downloadguix-06e8d0c8e5179d79bd04afed197b9365d85f1cf7.tar.gz
gnu: dash: Update to 0.5.9.1.
* gnu/packages/shells.scm (dash): Update to 0.5.9.1.
[source]: Use git-fetch.
[native-inputs]: Add autoconf and automake.
[arguments]: Add 'bootstrap' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shells.scm25
1 files changed, 19 insertions, 6 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 0cbd3a53e1..ca51b3ad5d 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2016 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -48,15 +49,20 @@
 (define-public dash
   (package
     (name "dash")
-    (version "0.5.9")
+    (version "0.5.9.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "http://gondor.apana.org.au/~herbert/dash/files/"
-                           name "-" version ".tar.gz"))
+       ;; The canonical source is offline, so we fetch the source code
+       ;; from the Git repository. See:
+       ;; https://www.mail-archive.com/dash@vger.kernel.org/msg01323.html
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://git.kernel.org/pub/scm/utils/dash/dash.git/")
+              (commit (string-append "v" version))))
+       (file-name (string-append name "-" version "-checkout"))
        (sha256
         (base32
-         "17328wd9n5krr5wd37smrk0y7fdf8aa3hmhm02br5mqpq0a3nycj"))
+         "0p01vx7rbyf5hyyaff7h8cbhq81bm5fmq1m933484lncl9rafcai"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -67,10 +73,17 @@
               "a command interpreter based on the original Bourne shell"))
            #t))))
     (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)))
     (inputs
      `(("libedit" ,libedit)))
     (arguments
-     `(#:configure-flags '("--with-libedit")))
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'bootstrap
+           (lambda _ (zero? (system* "autoreconf" "-vfi")))))
+       #:configure-flags '("--with-libedit")))
     (home-page "http://gondor.apana.org.au/~herbert/dash")
     (synopsis "POSIX-compliant shell optimised for size")
     (description