summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2021-05-13 08:38:18 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2021-05-13 08:45:36 +0300
commit08814ccc54fe509da096d1a87572d4c36c1aeced (patch)
tree6446a03ed1750a2f1963d7cdd7b10a0d37e043c4 /gnu
parent696cf48b98ad4ef03c88cdb5a83c739618c8fa16 (diff)
downloadguix-08814ccc54fe509da096d1a87572d4c36c1aeced.tar.gz
gnu: guile-bash: Build with Guile 3.0.
* gnu/packages/guile-xyz.scm (guile2.0-bash): New variable.
(guile-bash): Build with Guile 3.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 67c6a7f125..18a3ced03a 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -37,6 +37,7 @@
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
 ;;; Copyright © 2021 Zelphir Kaltstahl <zelphirkaltstahl@posteo.de>
+;;; Copyright © 2021 Oleg Pykhalov <go.wigust@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -362,7 +363,7 @@ $(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
 dictionary and suggesting spelling corrections.")
     (license license:gpl3+)))
 
-(define-public guile-bash
+(define-public guile2.0-bash
   ;; This project is currently retired.  It was initially announced here:
   ;; <https://lists.gnu.org/archive/html/guile-user/2015-02/msg00003.html>.
   (let ((commit "1eabc563ca5692b3e08d84f1f0e6fd2283284469")
@@ -431,6 +432,25 @@ enable -f ~/.guix-profile/lib/bash/libguile-bash.so scm
 and then run @command{scm example.scm}.")
       (license license:gpl3+))))
 
+(define-public guile-bash
+  (package
+    (inherit guile2.0-bash)
+    (name "guile-bash")
+    (inputs
+     `(("guile" ,guile-3.0-latest)
+       ,@(assoc-remove! (package-inputs guile2.0-bash) "guile")))
+    (arguments
+     `(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-after 'install 'install-guile
+                    (lambda* (#:key inputs outputs #:allow-other-keys)
+                      (copy-recursively
+                       (string-append (assoc-ref outputs "out")
+                                      (assoc-ref inputs "guile") "/share")
+                       (string-append (assoc-ref outputs "out") "/share"))
+                      #t)))
+       ,@(package-arguments guile2.0-bash)))))
+
 (define-public guile-8sync
   (package
     (name "guile-8sync")