summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-04-02 01:22:25 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-02 11:16:49 +0200
commit0ad7e703c9adbb14f05378d5e25573d859829991 (patch)
treef754c730fd60bd63a831229031e8c60b1ac621f2 /gnu
parent24a3eb9084701f63f468ba207eeb0dc6788bf267 (diff)
downloadguix-0ad7e703c9adbb14f05378d5e25573d859829991.tar.gz
gnu: nethack: Make some inputs native.
* gnu/packages/games.scm (nethack)[inputs]: Move flex & bison from here...
[native-inputs]: ...to this new field.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8a24dad33d..4d4b2b0b05 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -50,6 +50,7 @@
 ;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
 ;;; Copyright © 2020 Vitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1293,10 +1294,11 @@ watch your CPU playing while enjoying a cup of tea!")
                         (string-join (string-split version #\.) "") "-src.tgz"))
         (sha256
           (base32 "1liyckjp34j354qnxc1zn9730lh1p2dabrg1hap24z6xnqx0rpng"))))
+    (native-inputs
+      `(("bison" ,bison)
+        ("flex" ,flex)))
     (inputs
       `(("ncurses" ,ncurses)
-        ("bison" ,bison)
-        ("flex" ,flex)
         ("less" ,less)))
     (build-system gnu-build-system)
     (arguments