summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-03-26 23:12:53 +0100
committerLudovic Courtès <ludo@gnu.org>2020-04-02 11:48:24 +0200
commit0f4be78fef122aad86f039b5e21d11a232e7cd88 (patch)
tree21d0497426965a24630d97fc5100a9bb6b79851b /gnu
parent5c83dd1d64783d4829e42714be41f4c4b0430dbd (diff)
downloadguix-0f4be78fef122aad86f039b5e21d11a232e7cd88.tar.gz
gnu: Add cramfs-tools.
* gnu/packages/linux.scm (cramfs-tools): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 945c15d972..ff069723c1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4368,6 +4368,40 @@ repair and easy administration.")
 from the btrfs-progs package.  It is meant to be used in initrds.")
     (license (package-license btrfs-progs))))
 
+(define-public cramfs-tools
+  (package
+    (name "cramfs-tools")
+    (home-page "https://github.com/npitre/cramfs-tools")
+    (version "2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32 "183rfqqyzx52q0vxicdgf0p984idh3rqkvzfb93gjvyzfhc15c0p"))
+              (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f                      ; No tests.
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (install-file "mkcramfs" (string-append out "/sbin"))
+               (install-file "cramfsck" (string-append out "/sbin")))
+             #t)))))
+    (inputs
+     `(("zlib" ,zlib)))
+    (synopsis "Tools to manage Cramfs file systems")
+    (description "Cramfs is a Linux file system designed to be simple, small,
+and to compress things well.  It is used on a number of embedded systems and
+small devices.  This version has additional features such as uncompressed
+blocks and random block placement.")
+    (license license:gpl2+)))
+
 (define-public compsize
   (package
     (name "compsize")