summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 10:16:05 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:50:59 +0100
commit213114a7b1ea34dbc492335ea4f8be4874c686c6 (patch)
tree5dbfec427624879d3fc54f4e1db34f203be98fa3 /gnu
parent16572d0e021d4a6caf8b3ba548ecf39883c47c24 (diff)
downloadguix-213114a7b1ea34dbc492335ea4f8be4874c686c6.tar.gz
gnu: daemontools: Don't assume sources match NAME.
* gnu/packages/admin.scm (daemontools)[source, argumenst]: Hard-code
name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c8533bfca8..576b242756 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -219,8 +219,8 @@ interface and is based on GNU Guile.")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "https://cr.yp.to/" name "/"
-                    name "-" version ".tar.gz"))
+                    "https://cr.yp.to/daemontools/"
+                    "daemontools-" version ".tar.gz"))
               (sha256
                (base32
                 "07scvw88faxkscxi91031pjkpccql6wspk4yrlnsbrrb5c0kamd5"))))
@@ -231,7 +231,7 @@ interface and is based on GNU Guile.")
        (modify-phases %standard-phases
          (add-after 'unpack 'chdir
            (lambda _
-             (chdir ,(string-append name "-" version))
+             (chdir ,(string-append "daemontools-" version))
              #t))
          (delete 'configure)
          (add-before 'build 'patch