summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-24 22:09:26 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 02:17:02 +0200
commit2a49f7ad5106778df5ef69197ca0dad4e8a16185 (patch)
treed39cf33bd1945f4e665411c0bffaa726540b1c35 /gnu
parent99f6ef9ab4b508e5081b5bf6e031054a7e04cec1 (diff)
downloadguix-2a49f7ad5106778df5ef69197ca0dad4e8a16185.tar.gz
gnu: go@1.4: Return #t from all phases.
* gnu/packages/golang.scm (go-1.4)[arguments]: Substitute INVOKE for
SYSTEM*. Return #t rather than undefined from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ea6ca2286c..ec574acdda 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -78,7 +78,8 @@
          (delete 'configure)
          (add-after 'patch-generated-file-shebangs 'chdir
            (lambda _
-             (chdir "src")))
+             (chdir "src")
+             #t))
          (add-before 'build 'prebuild
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((gcclib (string-append (assoc-ref inputs "gcc:lib") "/lib"))
@@ -160,7 +161,7 @@
                ;; Go 1.4's cgo will not work with binutils >= 2.27:
                ;; https://github.com/golang/go/issues/16906
                (setenv "CGO_ENABLED" "0")
-               (zero? (system* "sh" "all.bash")))))
+               (invoke "sh" "all.bash"))))
 
          (replace 'install
            (lambda* (#:key outputs inputs #:allow-other-keys)