summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 18:30:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 18:36:59 +0200
commit2c6b6d7991e978369f577d3021a46c3b973fb850 (patch)
tree7f8186add948c956e635db7ba051eebeebd1a954 /gnu
parent2933e4d465ecc515d11f9ac21fe72eecaf32b0b2 (diff)
downloadguix-2c6b6d7991e978369f577d3021a46c3b973fb850.tar.gz
gnu: libopenmpt: Remove 5.1-MiB static library.
* gnu/packages/audio.scm (libopenmpt)[arguments]: Add a
‘delete-static-libraries’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index bd9071e7b6..9447156e0e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -311,7 +311,15 @@ Linux kernel.")
     (arguments
      `(#:configure-flags
        (list (string-append "--docdir=" (assoc-ref %outputs "out")
-                            "/share/doc/" ,name "-" ,version))))
+                            "/share/doc/" ,name "-" ,version))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'delete-static-libraries
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (lib (string-append out "/lib")))
+               (for-each delete-file (find-files lib "\\.a$"))
+               #t))))))
     (native-inputs
      `(("doxygen" ,doxygen)
        ("perl" ,perl)