summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-13 00:14:21 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-26 18:50:09 +0100
commit2cb4ee2787281b0c155ab4794fa1251652251d3b (patch)
tree46d67f9d1384da58fee33745308622db285970a4 /gnu
parent87435943d1cf082b64fd2ee581e9db85b373ddb9 (diff)
downloadguix-2cb4ee2787281b0c155ab4794fa1251652251d3b.tar.gz
gnu: Add python-iocapture.
* gnu/packages/python-xyz.scm (python-iocapture): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6e9722c1fe..cd68b49572 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17375,3 +17375,25 @@ files.  These files are used to translate strings in android apps.")
     (description "This package provides pattern matching and various utilities
 for file systems paths.")
     (license license:expat)))
+
+(define-public python-iocapture
+  (package
+    (name "python-iocapture")
+    (version "0.1.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "iocapture" version))
+        (sha256
+         (base32
+          "1s3ywdr0l3kfrrqi079iv16g0rp75akkvx0j07vx9p5w10c0wrw6"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-flexmock" ,python-flexmock)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/oinume/iocapture")
+    (synopsis "stdout and stderr capture in Python")
+    (description "This package allows Python developpers to capture their standard
+output and standard error.")
+    (license license:expat)))