summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Sassmannshausen <alex@pompo.co>2016-06-29 16:43:16 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-02 16:24:35 +0200
commit2dca669e45a233ec1391897b65faf51e347ace05 (patch)
tree698c9c754694712d3d6788db8e3a557da85edf1a /gnu
parent7640c62dd2863fdc04115ccb9d7c30c079b26ea8 (diff)
downloadguix-2dca669e45a233ec1391897b65faf51e347ace05.tar.gz
gnu: Add perl-guard.
* gnu/packages/perl.scm (perl-guard): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1a0c8783d1..ae6ad8f18e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2530,6 +2530,29 @@ vaguely inspired by John Ousterhout's Tk_ParseArgv.")
                               "Getopt-Tabular-" version))
     (license (package-license perl))))
 
+(define-public perl-guard
+  (package
+    (name "perl-guard")
+    (version "1.023")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/M/ML/MLEHMANN/Guard-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1p6i9mfmbs9cw40jqdv71ihv2xfi0vvlv8bdv2810gf93zwxvi1l"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Guard")
+    (synopsis "Safe cleanup blocks implemented as guards")
+    (description "@code{Guard} implements so-called @dfn{guards}.  A guard is
+something (usually an object) that \"guards\" a resource, ensuring that it is
+cleaned up when expected.
+
+Specifically, this module supports two different types of guards: guard
+objects, which execute a given code block when destroyed, and scoped guards,
+which are tied to the scope exit.")
+    (license (package-license perl))))
+
 (define-public perl-hash-merge
   (package
     (name "perl-hash-merge")