summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-09-01 10:48:19 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-01 22:22:22 +0200
commit37c08f42f7551203e98384c13ecfd33b57df40e6 (patch)
treebb03a48f8c3fa802b3d033bab71d85bcdac763c1 /gnu
parent5f39050b1eb74d371bd1ddabeb40d4339cc35158 (diff)
downloadguix-37c08f42f7551203e98384c13ecfd33b57df40e6.tar.gz
gnu: txr: Update to 224.
* gnu/packages/lisp.scm (txr): Update to 224.
  [source]: Use git-fetch instead of fetching a cgit snapshot.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 34edea41de..ab1c84262e 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5337,17 +5337,18 @@ port within a range.")
 (define-public txr
   (package
     (name "txr")
-    (version "223")
+    (version "224")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "http://www.kylheku.com/cgit/txr/snapshot/txr-"
-                           version
-                           ".tar.bz2"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "http://www.kylheku.com/git/txr/")
+             (commit (string-append "txr-" version))))
+       (file-name (git-file-name name version))
        (patches (search-patches "txr-shell.patch"))
        (sha256
         (base32
-         "0109q8idqggba3kx58dpm5ccfpdrki68npkcxm18p5ga24611fcv"))))
+         "1036k71f6mffy9rjwzmhr5nnp1n0wzb0rqvilpzvb8jc5yxv0810"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("cc=gcc")